startsida < företaget < organis. < datorer < frågor
 
Tabeller

 
  Frågor och svar
Allmänt
Tabeller
Kalkylering 1
Kalkylering 2
Text och format
Tid och datum
Tekniska problem
   
  Innehåll
expowera

Materialet publicerat med tillstånd från Dennis Wallentin.

F: Jag har två tabeller, namngivna till Tabell1 och Tabell2. I cell H2 anger jag tabellnamnet, uppslagsvärdet i cell E2 och vill i cell C2 få fram utfallet. Hur refererar jag till tabellnamnet i cell H2?

S: Jo, det måste ske med funktionen INDIREKT enligt följande:
=LETARAD(E2;INDIREKT(H2);3;0)


F: Använder ofta verktyget Autofilter. Vid urval via verktygets menyner visas inte alla poster i menyn - Stämmer det?

S: Ja, det stämmer att "drop-downmenyerna" endast kan visa maximalt 1.000 st unika poster. För att gå runt denna begränsning rekommenderas alternativet "Anpassas" eller att det sker en stegvis filtrering som ej överstiger 1.000 unika poster.

Varken funktionaliteten eller resultat av filtreringar påverkas ej av denna begränsning.


F: Jag har en lista med artikelhuvudserier, där varje serie (AA, BB, CC, DD osv) representerar en artikelgruppnamn (1,2,3 osv).
Jag vill kunna ange i cell ett artikelnummer och erhålla i retur artikelns grupptillhörighet - hur kan det ske?

S: Lösningen ligger i att vi extraherar de två första tecknen i artikelnumret vi vill identifiera m h t grupptillhörighet:
=INDEX(Artikelgruppnamn;PASSA(VÄNSTER(A2;2);Artikelhuvudserie;0))
eller
=LETARAD(VÄNSTER(A2;2);C2:D100;2;0)


F: Hur får jag enklast fram det senaste inmatade värdet i en kolumn?

S: Det sker bäst med följande formel:
=INDIREKT("B" & (ANTALV(B:B)))


Formeln kan anpassas helt efter situation, dock måste det hela tiden avse en kolumn.


F: Från en kolumn vill jag leta fram det största värdet och hämta värdet från den intilliggande kolumnen på samma rad.

S: Försök med följande formel:
=LETARAD(MAX(A:A);A:B;2;FALSKT)


F: Jag har en tabell med två kolumner, datum och värden. I en annan del av kalkylbladet vill jag visa det senaste inmatade värdet utifrån det senaste angivna datumet.

S: Det kan lösas på följande sätt:
=LETARAD(MAX(Datum);Tabell;2)

"Datum" refererar till den kolumn i tabellen som innehåller datum. MAX-funktionen hämtar det största datumvärdet (=det senaste angivna datumet).


F: Ibland förekommer det numeriska värden i en kolumn som egentligen ska innehålla text. Jag har inte lyckats få till formeln för att kunna söka även dessa värden. Kan du hjälpa mig?

S: Ett sätt att lösa det är mha formeln:
=LETARAD(TEXTNUM(Letauppvärde);Tabell;Kolumnindex)

Den kan med fördel användas i en OM-formel.

Om den omvända situationen föreligger, dvs det förekommer textvärden i en kolumn som egentligen ska innehålla numeriska värden, kan följande formel användas:
=LETARAD(TEXT(Letauppvärde;"0");Tabell;Kolumnindex)


F: Jag har två listor, där jag vill ha reda på hur många poster i båda listorna som har samma månad. Vidare vill jag också kunna summera de poster som uppfyller villkoret.

S: För att erhålla antal poster kan följande formel användas:
=PRODUKTSUMMA((MÅNAD($A$1:$A$4)=4)*(MÅNAD($B$1:$B$4)=4))

För att erhålla summan av dessa poster kan följande formel användas:
=PRODUKTSUMMA((MÅNAD($A$1:$A$4)=4)*(MÅNAD($B$1:$B$4)=4)*C1:C4)


F: Jag har en lång lista ur vilken jag vill få fram antalet som överensstämmer med sökvillkoret. Villkoret är en delmängd av cellernas text, såsom V14 som återfinns i flera artikelbenämningar.

S: Här får vi ta hjälp av tecknet * på följande sätt:
=ANTAL.OM(A1:A3;"=*V14*")

Då vi inte vet antal tecken före eller efter villkoret måste vi här använda oss av *-tecknet.


F: Hur måste man göra för att kunna sortera 6 kolumner?

S: XL:s inbyggda sorteringsfunktion tar 3 kolumner. Vi måste därför skapa förutsättningar för att få XL att sortera de önskade antalet kolumner:

Skapa en ny kolumn

Skriv in följande generella formel och kopiera den nedåt:
=A:A&B:B&C:C&D:D&E:E&F:F

Om teckenlängden varierar i en kolumn måste man ta hänsyn till det genom att för varje kolumn komplettera formeln ovan med
VÄNSTER(A:A&" ";20)


F: Kan man automatiskt skapa en numrerad lista, dvs man fyller på med tal och XL ger tabellnummerna?

S: Jo, det kan man mha följande formel, som kopieras nedåt i kolumnen: =OM(A1<>"";ANTALV($A$1:A1)&".";"")


F: I en kolumn har jag namn och i den andra kolumnen finns försäljningsintäkter per namn. Hur kan jag få fram vem som har högsta respektive lägsta försäljningen för perioden?

S: För att få fram den lägsta försäljningen / period:
=INDEX(A1:A4;PASSA(MIN(B1:B4);B1:B4;0))

För att erhålla högsta försäljningen så ersätts MIN med MAX-funktionen.

Om flera poster har lägsta/högsta värdet returneras det första namnet.


F: Jag vill utifrån 5 (!) villkor få fram värden i en tabell. I värdetabellen kan det förekomma text - går det?

S: Jo, men det blir en ganska "ful" formel enligt följande;
=SUMMA((A2&B24&C2&D2&E2=Omr1&Omr2&Omr3&Omr4&Omr5)
*OM(ÄRTAL(Värdekolumn);Värdekolumn))


F: Vid import får jag värden såsom DEF123456789 och B123456789. Jag vill kunna få fram de 9 siffrorna, dvs inga bokstäver.

S: Formeltekniskt går det att lösa på följande sätt:
{=EXTEXT(A1;PASSA(FALSKT;ÄRFEL(1*EXTEXT(A1;RAD($1:$100);1));0);9)}

Alternativt kan man använda sig av funktionen "text till kolumner..." och ta bort de överflödiga kolumnerna.


F: Jag arbetar med större listor, där jag gör utsökningar och resultatet kopieras till andra blad. Kan man kopiera enbart synliga celler?

S: Detta är en ganska vanlig situation, att extrahera data ur listor och förädla den vidare. Lösningen är att använda sig av "Gå till special". Välj kommandot Redigera / Gå till / Special och markera "Enbart synliga celler". Därefter kan du utföra kopiering - och klistra in - kommandon.


F: Kan jag dölja enstaka celler utan att dölja hela kolumnen/raden?

S: Tekniskt sett nej men det finns s k "workarounds" för problemet.
- Använd samma färg för celldatan som för bakgrund, t ex vit.
- Använd talformatet - ";;;" - så döljs celldatan.
- Skydda arbetsbladet, men innan dess väljs kommandot Format / Celler och under fliken "Skydd" bockas alternativet "Dold" för.


F: Kan jag förenkla tillvaron vid större beräkningar, d v s att jag slipper kopiera samma formler t ex 1000 rader ned i en kolumn?

S: Jo, skapa din formel för första raden. Dubbelklicka på fyllningshandtaget.


F: Hur tar jag bort dubbletter i en lista?

S: Markera listan och välj kommandot Data/Filter/Avancerat Filter. I dialogrutan markeras alternativet "unika poster" och därefter väljs ett målområde för den unika listan.


F: Hur kopierar jag data från enbart synliga celler i en filtrerad lista?

S: Markera det cellområde som ska kopieras. Välj kommandot Redigera / Gå Till. I dialogrutan väljs knappen "Special". Markera alternativet "Enbart synliga celler". Utför därefter kopiera - / klistra in - kommandona.


F: Hur tar man bort tomma celler i en kolumn / rad?

S: Markera hela kolumnen/raden, välj kommandot Redigera / Gå Till.
I dialogrutan väljs knappen "Special". Markera alternativet "Tomma celler". Välj kommandot Redigera / Ta bort.

Upp
Senast uppdaterad: 2005-10-05 © Dennis Wallentin