startsida < företaget < organisera < datorer < tips
 
Diagram

 
  Tips & Trix
Kalkylering
Tabeller
Diagram
Text
Utskrifter
Diverse
Kontroller
Makrofunktioner
Snabbtips
Tema
   
  Innehåll
expowera

 

Materialet publicerat med tillstånd från Dennis Wallentin.

Dynamiska dataserier
Om du t ex dagligen uppdaterar källdatan manuellt kan användandet av dynamiska serier avsevärt reducera tidsåtgången.

Exemplet utför från följande tabell:

  • Välj kommandot Infoga / Namn / Definiera.
     
  • I textfältet "Definierade Namn" anges "Period".
     
  • I fältet "Refererar till" anges följande formel:
    =FÖRSKJUTNING(Blad1!$A$2;0;0;ANTALV(Blad1!$A:$A)-1)

Klicka på Lägg Till-knappen. Notera att funktionen FÖRSKJUTNING refererar till den första datapunkten (cell A2) och använder funktionen ANTALV för att få fram antal datapunkter i kolumn A. Kolumn A har ju en rubrik - Period - i cellen A1 varför formeln reducerar antal datapunkter med 1.

  • Lägg till namnet "Volym" enligt ovan men referera istället till följande formel: =FÖRSKJUTNING(Blad1!$B$2;0;0;ANTALV(Blad1!$B:$B)-1)
     
  • Aktivera staplarna i diagrammet genom att klicka på dem. I formelfältet anges formeln:  =SERIER(;Period;Volym;1)

Dynamisk titel
Ibland är det önskvärt att diagramtiteln ändras automatiskt, t ex vid användning av Pivottabeller som källdata.

  • Skapa titeln i en cell.
     
  • Aktivera diagramtiteln genom att klicka på den.
     
  • Skriv in "=" i formelfältet.
     
  • Klicka på den cell som innehåller titeln

Nollvärden i dataserier
Det kan ibland uppstå problem att vissa datapunkter visar 0-värden, t ex vid användning av en funktion där resultatet blir 0 och man inte vill ta bort de underliggande formler. Problemet som därmed kan uppstå är att diagrammet (i synnerhet vid användning av linjediagram) blir missvisande, dvs det är inte önskvärt att visa nollvärden.

Antag att vi har en summering av intervallet A4:A20, dvs =SUMMA(A4:A20). Nedanstående formel ger den tekniska lösningen på problemet:

  • =OM(SUMMA(A4:A20)=0;SAKNAS();SUMMA(A4:A20))

OM-funktionen evaluerar huruvida funktionen ger resultatet 0 eller inte. Om resultatet blir 0 så ska SAKNAS-felmeddelandet visas.

Om det av tidsbrist eller annat skäl inte önskas använda denna formel kan man helt enkelt bara ange =SAKNAS().

Om man inte vill visa felmeddelandet "SAKNAS!" så kan det döljas genom att man skapar ett eget talformat.

  • Välj kommandot Format / Celler.
     
  • Välj fliken "Tal" och välj där kategori "Anpassat".
     
  • I textfältet "Typ" skrivs följande talformat in:
    [Svart]Standard;[Röd]Standard;[Svart]Standard;[Vit]Standard

Tomma celler i dataserier
Om man har brutna dataserier, dvs tomma celler i dataserier, så visas dessa inte i digrammet. Hur ska man göra för att visa hela serier i diagram?

  • Aktivera diagrammet genom att klicka på den.
     
  • Välj kommandot Verktyg / Alternativ och fliken "Diagram".
     
  • För "Låt tomma celler...." väljs alternativet "Interpolerat värde".

XL räknar ut ett värde för de datapunkter som saknar värde genom att beräkna det föregående och det efterkommande datapunkters värde. Som framgår av dialogrutan finns det ytterligare alternativ att välja på.

Skapa diagramblad
Genvägar är oftast mycket tidsbesparande men bygger samtidigt på att man har en god struktur. För bästa resultat bör man har skapat ett eget standarddiagram, dvs en diagrammall.

  • Markera källdatan - Är det en sammanhängande tabell kan man använda tangentbordskommandot CTRL+SKIFT+*.
     
  • Tryck på F11-knappen - Voila!

Visa värden direkt vid Y-axeln
Antag att vi har etiketter som börjar på 0 och där det första datavärdet önskas visas direkt vid Y-axeln.

Bilden nedan visar exemplet i sin helhet:

För att få till denna lösning behöver vi utföra följande kommando:

  • Markera x-axeln
     
  • Välj kommandot Format | Axel...
     
  • i dialogrutan avbockas alternativet "Värdeaxel (Y) korsar mellan kategorierna" under fliken "Skala".

Om detta inte fungerar så måste följande moment utföras efter det att diagrammet har skapats:

  • Markera serien för etiketterna och välj ett kopieringskommando.
     
  • Aktivera diagrammet genom att klicka på det.
     
  • Välj kommandot Redigera | Klistra in special.
     
  • I dialogrutan bockas alternativen "Kategorier (X-etiketter) i första raden" och "Ersätt befintliga kategorier" för.

Styra antalet poster
I vissa sammanhang kan det vara önskvärt att styra antalet poster som ska visas i diagram.

Antag att vi har en serie i kolumnen A och antal poster som ska visas återfinns i cellen B2.

Följande bild visar exemplet i sin helhet:

Grundformeln hämtas från Dynamiska dataserier men där vi ändrar på den senare delen av formeln.

För att beakta värdet i cellen B2 (antal poster )används formeln:

  • =ANTALV(A:A)-(ANTALV(A:A)-B2)

När vi skapar namnet för det önskade cellområdet, dvs diagrammets dataserie, ska namnet referera till följande formel:

  • =FÖRSKJUTNING(AntalRader!$A$2;0;0;ANTALV(AntalRader!$A:$A)-
    (ANTALV(AntalRader!$A:$A)-AntalRader!$B$2))

En betyldigt enklare formel än den ovan är:

  • =FÖRSKJUTNING(AntalRader!$A$2;0;0;AntalRader!$B$2)

I diagrammets SERIE-funktion ersätt referensområdet med namnet enligt följande:

  • =SERIE(;;Diagram.xls!Område;1)

Autofilter o diagram
Det är ganska vanligt att man skapar en tabell för hela året och att redovisning sker per månad. Därefter fylls månadsdata löpande i tabellen.

Följande bild visar detta scenario:

Nackdelen är förstås att diagrammet visas perioder som saknar data och innehåller därför överflödig information.

Hur ska vi göra för att eliminera de perioder som saknar data? Det vi vet är att Excel endast visar synliga celler i diagram och därför kan vi använda oss av Autofilter för att dölja poster som saknar data (eller t ex har data som understiger ett visst värde e d).

Villkoret för att filtrera poster utgörs av "Ifyllda" och detta villkor kan vi ange för första dataserien ( i exemplet för artikelgruppen 1).

Bilden nedan visar tabell och diagram efter det att filtrering har skett:


 

Upp
Senast uppdaterad: 2005-10-05 © Dennis Wallentin