startsida < företaget < organisera < datorer < tips
 
Kalkylering I

 
  Kalkylering
Kalkylering I
Kalkylering II
Kalkylering III
Kalkylering IV
Kalkylering V
Kalkylering VI
Kalkylering VII
Villkorsstyrd
kalkylering
Villkorsstyrd
formatering I
Villkorsstyrd
formatering II
Felhanterings-
kalkylering
Matriskalkylering I
Matriskalkylering II
Matriskalkylering III
Matriskalkylering IV
Matriskalkylering V
Datumkalkylering I
Datumkalkylering II
Datumkalkylering III
Datavalidering I
Datavalidering II
Cirkelreferenser
   
  Innehåll
expowera

 

Materialet publicerat med tillstånd från Dennis Wallentin.

Beräkning visad precision
Ibland uppfattas det som att XL "räknar fel". Detta gäller främst vid beräkning av tal med decimaler. Följande tabell beskriver bäst situationen. I första kolumnen är talen oformaterade, kolumnen därefter har talen formaterats till att visa två decimaler. I den sista kolumnen är beräkningen korrigerad.

Oformaterad Formaterad Precision
1,002 1,00 1,0
1,002 1,00 1,0
1,002 1,00 1,0
3,006 3,01 3,0
  • Välj kommandot Verktyg / Alternativ.
     
  • I dialogrutan väljs bladfliken "Beräkning" och under arbetsboksalternativ aktiveras "Visad precision".

OBS! Vid användning av denna inställning förloras permanent de underliggande värdenas precision.

Cirkumflexberäkning
Att räkna med upphöjda tal kan göras på två sätt. M h a funktionen UPPHÖJT.TILL kan önskat resultat erhållas. Det snabbare sättet är att helt enkelt använda sig av den s k cirkumflexoperatorn "^".

Anta att värdet 3 finns i cell A1 och värdet 2 i cellen A2. Det vi vill räkna fram är 3 upphöjt med 2. I resultatcellen matas följande formel in: =A1^A2.

Kalkylbladsberäkningar
Har man flera kalkylblad som t ex ska summeras ihop finns det olika sätt att lösa det på.

Anta att man vill summera värden i cellen A1 från kalkylbladen "Blad1" t o m "Blad4": =SUMMA(Blad1:Blad4!A1)

Om namn på de kalkylblad man vill utföra beräkningar på är av samma namntyp, t ex "Blad"x, så kan en annorlunda inmatning av formeln avsevärt reducera tiden. Genom att ange =SUMMA(Blad?!A1) så genererar XL resultatet =SUMMA(Blad1:Blad4!A1).

Kolumn- & Radberäkningar
Det kan emellanåt underlätta att summera hela kolumner eller hela rader i stället för avgränsade cellområden. Det gäller i synnerhet när man inte vet hur många celler som ska summeras, dvs underlaget uppdateras löpande.

Istället för att t ex ange =SUMMA(A2:A40) så kan man ange =SUMMA(A:A).

För radberäkning kan en summaberäkning se ut på följande sätt: =SUMMA(1:1)

Ett alternativ till ovanstående är att använda sig av dynamiska dataserier.

Fasta decimaler
Vid inmatning av ekonomisk data och som innehåller decimaler, t ex 13456,78 kr, kan arbetet underlättas. Istället för att själv ange decimaltecknet vid inmatning kan man överlåta det till XL, dvs man anger 1345678 och XL visar 13456,78.

  • Välj kommandot Verktyg / Alternativ.
     
  • I dialogrutan väljs fliken "Redigering" och alternativet "Fasta decimaler" aktiveras samt bestäm antal decimaler.

OBS! Denna ändring påverkar XL:s allmänna inställningar för arbetsböcker.

Manuell beräkning
Har man stora kalkyler med många beräkningar i kan man stänga av den automatiska beräkningsfunktionen. I synnerhet underlättas inmatning av ny data.

  • Välj kommandot Verktyg / Alternativ.
     
  • Välj fliken "Beräkning" i dialogrutan och i beräkningsalternativen välj "Manuell".
     
  • Efter ny data har skrivits in tryck på F9-tangenten för beräkning.

OBS! Denna ändring påverkar XL:s allmänna inställningar för arbetsböcker.

Snabb uppdatering
Det snabbaste sättet att uppdatera t ex ett budgetunderlag med 10 % är att:

  • Skriv in 10 % i en cell i kalkylbladet.
     
  • Välj kommandot Redigera / Kopiera.
     
  • Markera de celler som ska uppdateras.
     
  • Välj kommandot Redigera / Klistra in special.
     
  • I dialogrutan väljs under "Åtgärd" alternativet "Multiplicera" .

Namnge konstanter
Anta att det förekommer fasta värden, s k konstanter, i en kalkyl. Hur gör man för att uppdatera dessa på snabbast sätt?

Att använda namn för konstanter är både ett lättförståeligt och snabbt sätt vid uppdatering. Vid uppdatering ändras namnreferensens värde, t ex 10 % till 12 % och XL räknar automatiskt om formlerna i kalkylbladet.

  • Välj kommandot Infoga / Namn / Definiera.
     
  • I dialogrutan anges i textrutan för "Definierade namn" det önskade namnet, t ex "Skattesats" - för att använda två ord måste dessa bindas samman med tecknet för understrykning, t ex "antal_procent".
     
  • I textrutan för "Refererar till" anges t ex =10 % .
     
  • I kalkylbladets formler refereras till "Skattesats", t ex =A6*Skattesats.

XL som miniräknare
Man kan ibland spara tid genom att låta XL fungera som en miniräknare. Det är också ett snabbare räkneförfarande än att aktivera kalkylatorn i Windows och överföra resultatet från den till XL.

  • Skriv in den önskade formeln i en cell men innan inmatningen bekräftas så tryck på F9-tangenten.

Arbetar man med t ex komplexa matrisformler kan det vara ett bra sätt att felsöka formeln m h a F9-tangenten.

  • Markera del av formeln och tryck på F9-tangenten!

Funktionen PRODUKT
Istället för att använda " * "-tecknet vid multiplikation kan man använda sig av funktionen PRODUKT. Funktionen tar både enstaka celler som cellområden som argument. Fördelen med den är att den bara utför multiplikation där det finns numeriska värden, dvs finns inga numeriska värden utförs inte heller någon multiplikation. Felvärden elimineras helt och hållet.

En annan närliggande funktion är matrisfunktionen MMULT, vilken utför multiplikation av två matriser.

Funktionen PRODUKTSUMMA
Funktionen PRODUKTSUMMA är en närbesläktad funktion till PRODUKT-funktionen. Förutom att den utför multiplikation sker också en summering av erhållna tal. Detta är den generella ansatsen för funktionen men här presenteras den i en annorlunda form.

Antag att vi vill erhållna antal förekomster av ett visst värde givet att ett eller flera villkor uppfylls. I nedanstående exempel ska vi se hur vi löser det mha PRODUKTSUMMA.

I exemplet finns det två villkor, cellen B2 ska innehålla värdet "A" och talen ska vara större eller lika med 12 men inte större än 56 (intervalvillkoret).

Formeln som ger rätt antal är:

  • =PRODUKTSUMMA((B2="A")*(A2:A5>=12)*(A2:A5<=56))

Antag istället att villkorscellen ska innehålla ett värde större än 7 men mindre än 12 och att antalet ska beräknas för värdet "CC".

Formeln som ger rätt antal är:

  • =PRODUKTSUMMA((B8>7)*(B8<12)*(A8:A12="CC"))

Formlerna kan även användas för listor i rader.

Formelmässigt sett kan den för många användare uppfattas som mer begriplig än matrisformler.

Avrunda små tal
Att avrunda tal uppåt eller nedåt kan ibland vara nödvändigt för att få önskad precision i beräkningarna. I XL finns det två inbyggda funktioner vi nu ska titta närmare på, AVRUNDA.UPPÅT och AVRUNDA.NEDÅT.

I det första exemplet (se nedan) visas hur funktionerna fungerar. Funktionerna tar två argument, tal som ska avrundas och antal decimaler som ska visas.

Antag att vi har en datalista som ska räknas upp med 15 % och där avrundning ska ske till närmaste 5-öres nivå. För att få avrundningar till dessa nivåer måste vi använda oss av faktorn 20 (100/5) samt multiplicera det med 1,15 (115%) och med värdet som ska räknas upp. Därefter måste en division med faktorn ske. I tabellen nedan visas den formeltekniska lösningen.

Generellt så kan man använda följande formel vid avrundningar:

Avrunda till:

Faktor

Formel

50 öre

0,50

=AVRUNDA(Tal/0,5;0)*0,5

25 öre

0,25

=AVRUNDA(Tal/0,25;0)*0,25

20 öre

0,20

=AVRUNDA(Tal/0,2;0)*0,2

10 öre

0,10

=AVRUNDA(Tal/0,1;0)*0,1

5 öre

0,05

=AVRUNDA(Tal/0,05;0)*0,05

Man kan även använda sig av MAVRUNDA-funktionen (ingår i Analys Toolpak).

Avrunda till:

Faktor

Formel

50 öre

0,50

=MAVRUNDA(Tal;0,5)

25 öre

0,25

=MAVRUNDA(Tal;0,25)

20 öre

0,20

=MAVRUNDA(Tal;0,20)

10 öre

0,10

=MAVRUNDA(Tal;0,10)

5 öre

0,05

=MAVRUNDA(Tal;0,05)

Är det negativa tal man ska avrunda måste faktorn också var negativ.

Avrunda stora tal
XL erbjuder flera möjligheter att avrunda tal. Vill du t ex avrunda till närmaste tiotusental kan det lösas m h a funktionen AVRUNDA alternativt med funktionen MAVRUNDA (ingår i Analys Toolpak).

Direkthjälpen ger tyvärr ingen vägledning när det gäller att avrunda heltal till t ex närmaste tusental eller tiotusental. "Decimalvärdet" i funktionen AVRUNDA måste vara negativt. I tabellen nedan framgår vilka negativa värden den måste anta för att avrunda till önskad nivå.

För avrundning till närmaste tiotal används faktorn "-1" och för avrundning till närmaste hundratal används "-2".

Istället för funktionen AVRUNDA kan funktionen MAVRUNDA användas. I tabellen nedan visas den multipel tal ska avrundas till.

För avrundning till närmaste tiotal används multipeln "10" och för avrundning till närmaste hundratal används "100".

Avrunda till heltal
Händer det ibland att du behöver avrunda till heltal, både positiva och negativa tal?

Den funktion man vanligtvis kopplar ihop med denna typ av problem är HELTAL.

Tekniskt sett så avrundar HELTAL-funktionen till det lägre närmaste heltalet och inte på basis av decimaldelen i talet, dvs 1,9 avrundas till 1 och inte till 2.

För positiva tal är det i sin ordning. Men vad händer med negativa tal när vi använder HELTAL?

I bilden nedan demonstreras utfallet tydligt. Funktionen ger -3 istället för -2, dvs =HELTAL(A3) avrundar nedåt.

För att komma runt detta problem så kan man istället använda sig av funktionen AVKORTA, vilken också hanterar positiva tal på samma sätt som HELTAL.

I exemplet föreligger följande formler:

  • Cell C2: =AVKORTA(A2)
     
  • Cell C3: =AVKORTA(A3)

Avrunda till önskat antal siffror
Antag att du har värden av varierande storlekar som du vill ska avrundas till såsom 4-siffriga tal.

Bilden nedan visar en en sådan uppställning:

Den tekniska lösningen innehåller en relativ okänd funktion i XL - LOG.

Följande formel ger lösningen och talet (här 3) styr antalet siffror som ska visas:

  • =AVRUNDA(A2;3-HELTAL(LOG(A2)))
     
Upp
Senast uppdaterad: 2005-10-05 © Dennis Wallentin