startsida < företaget < organisera < datorer < tips
 
Kalkylering III

 
  Kalkylering
Kalkylering I
Kalkylering II
Kalkylering III
Kalkylering IV
Kalkylering V
Kalkylering VI
Kalkylering VII
Villkorsstyrd
kalkylering
Villkorsstyrd
formatering I
Villkorsstyrd
formatering II
Felhanterings-
kalkylering
Matriskalkylering I
Matriskalkylering II
Matriskalkylering III
Matriskalkylering IV
Matriskalkylering V
Datumkalkylering I
Datumkalkylering II
Datumkalkylering III
Datavalidering I
Datavalidering II
Cirkelreferenser
   
  Innehåll
expowera

 

Materialet publicerat med tillstånd från Dennis Wallentin.

Slumpa fram namn
Antag att vi ska ta fram ett namn ur en namnlista. Namnet ska vara slumpmässigt valt och utan påverkan från användaren.

Här demonstreras en lösning som kan fylla sin funktion i flera sammanhang.

Utgångspunkten är följande namnlist:

För att slumpmässigt erhålla namn krävs två saker:

  • Att följande formel används:
    =FÖRSKJUTNING($A$1;TRANSPONERA(SLUMP()*6);0;1;1)
     
  • Att beräkning av kalkylbladet sker - Tryck på F9-tangenten

Talet 6 i formeln refererar till antalet namn som förekommer i namnlistan.

Summera värden i cellintervall
Antag att vi har en lista, där vi ska summera värdena i grupper om 3 tal - Hur ska det lösas?

Jo, en lösning är t ex utifrån tabellen nedan:

För att få summeringen enligt våra önskemål används följande formel:

  • =SUMMA(FÖRSKJUTNING($A$1;(RAD(1:1)-1)*3;0;3;1))

Skapa formeln och kopiera den nedåt i kolumnen. När all summering har gjorts erhålls värdet 0.

Har vi en annan rad att utgå ifrån än i exemplets rad 1 måste det beaktas. Vill vi ändra på antalet celler som ska summeras är det den sista 3:an i exemplet som ska justeras.

Givetvis kan även andra beräkningar utföras än summering.

Räkna med merkostnader
Antag att vi har följande situation:

Vid varje ökning av försäljningen, i ett 10.000 kr - intervall, ökar merkostnaderna med 4.000 kr. Dock sker det för belopp överstigande en viss försäljningsnivå.

Följande intervall föreligger:

  • 150.000 - 159.000 kr   Merkostnad / 10.000 kr : 0 kr
  • 160.000 - 169.000 kr   Merkostnad / 10.000 kr : 4.000 kr
  • 170.000 - 179.000 kr   Merkostnad / 10.000 kr : 8.000 kr
  • 180.000 - 189.000 kr   Merkostnad / 10.000 kr : 12.000 kr
  • osv

Bilden nedan visar utfallet för dessa intervall:

Formeln som ligger till för beräkningen ser ut enligt följande:

  • =MAX(0;HELTAL((A2-150000)/10000)*$D$2)

Formeln kopieras nedåt i B-kolumnen.

Sortering av alfanumeriska värden
I vissa sammanhang räcker inte XL:s inbyggda sorteringsfunktion till varför andra lösningar måste till.

Antag att vi har följande lista som vi önskar få sorterad stigande:

När vi använder oss av den inbyggda sorteringverktyget erhålls följande utfall:

För att komma till rätta med detta problem kan vi lägga till ytterligare en kolumn för sortering. Följande formel skapas och kopieras nedåt i kolumnen:

  • =VÄNSTER(A2;2)&TEXT(EXTEXT(A2;3;255)*1;"000")

Därefter väljs kommandot Data | Sortera och där sortering sker utifrån B-kolumnen i exemplet.

Resultatet blir såsom bilden nedan visar:

Utestående fordringar
I detta tipset belyses hr vi kan summera utestående fordringar för en period. Exemplet har sin utgångspunkt i följande uppställning:

Problemet kan lösas med ett av följande 4 alternativ (det finns flera!):

  • =PRODUKTSUMMA(ICKE(ÄRTAL(C2:C15))*B2:B15)
     
  • =PRODUKTSUMMA(N(ICKE(ÄRTAL(C2:C15)));B2:B15)
     
  • =SUMMA.OM(C1:C15;"";B1:B15)
     
  • =SUMMA(B2:B15)-SUMMA.OM(C1:C15;"<>";B1:B15)

Räkna förekomsten av flera värden
Här demonstreras tekniker för att räkna förekomsten av flera värden i en lista.

Exemplet har sin utgångspunkt i följande uppställning:

I den första lösningen används en enkel formel:

  • =SUMMA(ANTAL.OM(A2:A6;1)+(ANTAL.OM(A2:A6;2)))

I den andra lösningen används en mer komplicerad formel, vilken också innehåller de värden som antal ska beräknas för:

  • =PRODUKTSUMMA((A2:A6={1;2})*1)
Upp
Senast uppdaterad: 2005-10-05 © Dennis Wallentin