startsida < företaget < organisera < datorer < tips
 
Kalkylering VII

 
  Kalkylering
Kalkylering I
Kalkylering II
Kalkylering III
Kalkylering IV
Kalkylering V
Kalkylering VI
Kalkylering VII
Villkorsstyrd
kalkylering
Villkorsstyrd
formatering I
Villkorsstyrd
formatering II
Felhanterings-
kalkylering
Matriskalkylering I
Matriskalkylering II
Matriskalkylering III
Matriskalkylering IV
Matriskalkylering V
Datumkalkylering I
Datumkalkylering II
Datumkalkylering III
Datavalidering I
Datavalidering II
Cirkelreferenser
   
  Innehåll
expowera

 

Materialet publicerat med tillstånd från Dennis Wallentin.

Räkna med filter
Antag att vi har en lista med avdelningar och utfall. Antag vidare att vi gör ett urval av avdelningar och att vi då vill erhålla antal poster som förekommer i ett givet intervall bland de synliga cellerna.

Intervallet som antal poster ska räknas inom är >=10 och <=20

Här är listan innan filtrering sker:

Efter det att listan har blivit filtrerad utifrån Avd (=AA) så ser utfallet ut så här:

Så här ser formeln ut i cell D3:

  • =PRODUKTSUMMA(DELSUMMA(3;FÖRSKJUTNING
    (B2:B10;RAD(B2:B10 )-MIN(RAD(B2:B10 ));;1))
    *(B2:B10>=10)*(B2:B10<=20))

Erhålla det närmast högre värdet i en lista
I detta lilla tips demonstreras hur vi kan hämta värden ur listor som antingen är lika med det sökta värdet eller om det inte finns det närmast högre värdet.

Exemplet i sin helhet visas i följande bild:

För att erhålla värdet i A-listan används följande matrisformel:

  • {=INDEX(A2:A5;PASSA(SANT;(D1<=A2:A5);0))}

Värdet från B-listan hämtas på basis av det erhållna värdet i A-listan varför följande formel används:

  • =INDEX(B2:B5;PASSA(MINSTA(A2:A5;ANTAL.OM
    (A2:A5;"<"&D1)+1);A2:A5;0))

Senaste inmatade värdet i raden
Här i detta tips belyses en formelteknik för att alltid erhålla det senaste inmatade värdet i en rad. Lösningen förutsätter att inga tomma celler förekommer mellan värdena.

Bilden nedan visar exemplet i sin helhet:

Följande formel används:

  • =FÖRSKJUTNING(B2;0;ANTALV(2:2)-1)

PRODUKTSUMMA med flera villkor för en och samma kolumn
Tipset demonstrerar hur vi kan ställa flera villkor för en kolumn för att summera poster.

Förutsättningarna och dess lösning framgår i följande bild:

Villkoren är att summering ska ske för de poster vars produktnamn

  • Börjar på AZ och
     
  • Slutar på 1

Följande formel används:

  • =PRODUKTSUMMA((VÄNSTER(B2:B8;2)="AZ")
    *(HÖGER(B2:B8;1)="1")*C2:C8)
Upp
Senast uppdaterad: 2005-10-05 © Dennis Wallentin